wL Email Encrypter 1.0.2


Das WordPress-Plugin wL Email Encrypter hat erneut ein Update bekommen. In der Version 1.0.2 wurde ein Fehler behoben, der in der zukünftigen WordPress-Version 3.1 für einen fatalen Error sorgen würde.

Und es wurde der veraltete Filter the_content_rss mit dem neuen Filter the_content_feed ersetzt. wL Email Encrypter 1.0.2 benötigt deshalb ab jetzt mindestens WordPress 2.9, um vollständig funktionieren zu können.

Der Bug bezog sich auf den Conditional Tag is_feed(). Die Funktion wurde aufgerufen, bevor $wp_query gesetzt wurde. Bisher hat die Funktion in diesem Fall ein FALSE zurückgegeben. In WordPress 3.1 erzeugt dieser Fehler aber diesen Fehler:

Fatal error: Call to a member function is_feed() on a non-object in […]/wp-includes/query.php on line 318

Dieser Fehler ist jetzt behoben.

Das Update wird automatisch über die WordPress Update-Funktion verteilt. Alternativ kann man sich das Update auch direkt aus dem WordPress-Repository laden.

Danke an Odolyte für das Feedback.

Wenn jemand noch weitere Fehler findet, hinterlasst einfach einen Kommentar.


2 Antworten zu “wL Email Encrypter 1.0.2”

  1. It would be great if there was an option to turn off the email encryption when a user is logged in. The reason is that I have another plugin that automatically inserts the user’s email address into a form, which then is encrypted with ugly results.

    I can’t really imagine a situation where a spambot were logged into a WordPress site anyway, so maybe it doesn’t need to be an option!

    Thanks for a great plugin.

    • Thanks for the suggestion, Jeff.

      This makes sense and is quickly realized.
      I will soon release an update.