wL Email Encrypter 1.0.4


Das WordPress-Plugin wL Email Encrypter hat soeben die Version 1.0.4 erreicht. Das Update behebt einen Fehler in den Feeds.

Der Bug bewirkt, abhänging von den Einstellungen, dass unter Umständen die Email-Adressen in Feeds im Klartext angezeigt wurden. Deshalb rate ich jedem Nutzer zu diesem Update.

wL Email Encrypter ist ein von mir entwickeltes Plugin für WordPress, um Emails im Klartext vor einer Auslese durch Bots oder Harvester zu schützen.

Durch einen Fehler wurden für die Feeds die gleichen Einstellungen wie für Seiten und Artikel verwendet, unabhängig davon, welche Einstellung für die Feeds getroffen wurde.

Da es aber relativ unwahrscheinlich ist, dass jemand die Email-Adressen in Seiten und Artikel nicht geschützt hat, werden wohl so gut wie niemand Emails als Klartext im Feed gehabt haben.

Der Fehler lag an einem zu früh gesetzten Action Hook, sodass der Condition Tag „is_feed()“ noch nicht greifen konnte. Dieser Bug ist nun behoben.

Vielen Dank an Tobias für den Hinweis.

Das Plugin könnt ihr im offiziellen WordPress Plugin Verzeichnis herunterladen. Das Update wird demnächst auch über die WordPress interne Update-Funktion verteilt.

Wenn ihr weitere Fehler findet oder Wünsche zum Plugin habt, schreibt einfach einen Kommentar.

Ich wünsche euch viel Spaß mit diesem Update.